Change currency symbol site wide

Tagged: ,

Viewing 15 posts - 31 through 45 (of 52 total)
  • Author
    Posts
  • #470
    esteeven
    Participant

    I hope the attached is what you need.

    • This reply was modified 2 months ago by  esteeven.
    Attachments:
    You must be logged in to view attached files.
    #473
    esteeven
    Participant

    Hello
    Was the .sql dump okay? I hope so.
    Many thanks

    #474
    RRowley
    Participant

    No. I wanted an export of all database tables. There were only two tables in what you provided.

    #475
    esteeven
    Participant

    Sorry. I’m a little out of my comfort zone 🙂

    • This reply was modified 2 months ago by  esteeven.
    Attachments:
    You must be logged in to view attached files.
    #478
    RRowley
    Participant

    I figured out the issue. The product_id field in si_expense is unsigned and the id in the si_products is not. This characteristic difference exists on other fields that will be set as foreign keys. So I’ll have to figure out why this is (thought previous patches fixed this) and what should be done to fix it.

    #479
    esteeven
    Participant

    Brilliant. I hope you can find a solution 🙂

    #480
    RRowley
    Participant

    There are a number of settings in your database structure that do not reflect changes that the patch manager should have implemented. I think this all stems from the problems you initially had. In any case, I’d like you to do the following with your database.

    1. Download the “tsp_fixes.zip” file I’ve attached and extract the two files in it. You can keep these in the download directory. The two files in this archive are structure.sql and si_sql_patchmanager.sql.
    2. Export all data except the content of the si_sql_patchmanager table.
    3. Delete all tables from the database by doing the following:
      • In phpMyAdmin select the database name (tsp_invoices) to display all its tables.
      • Check the “Check all” box at the bottom of the list of tables.
      • Click on the “With selected” drop down list adjacent to the “Check all” option and select the “Drop” option in the “Delete data or table” category.
      • Uncheck the “Enable foreign key checks” box and then click the “Yes” button to delete all the tables and data.
      • Import the “structure.sql” file extracted in step 1. This will create all the tables with the proper structure.
      • Import your database content extracted in step 2. Be sure to uncheck the “Enable foreign key checks” in the “Other options” section of the Import screen.
      • Import the si_sql_patchmanager.sql file extracted in step 1.

    At this point, your database should be properly structured with your data in it. Access SI now to verify it is working properly. Let me know what happens and I’ll keep my fingers crossed for you.

    • This reply was modified 2 months ago by  RRowley.
    Attachments:
    You must be logged in to view attached files.
    #483
    esteeven
    Participant

    Okay. I’ll try this tomorrow morning and report back. Fingers crossed 🙂

    ps thanks for your time and effort!!

    edit : Saturday@ 16:00 BST
    I’m having some issues with my server so the procedure will have to wait until tomorrow 🙁

    • This reply was modified 2 months ago by  esteeven.
    #485
    esteeven
    Participant

    Hello
    When I import the data, I get the following error.

    Attachments:
    You must be logged in to view attached files.
    #487
    RRowley
    Participant

    You need to follow the steps I outlined exactly. This error tells me that you did not DROP the tables per 3c.

    #488
    esteeven
    Participant

    I am following the steps exactly as outlined. The error message for si_biller remains the same.

    Attachments:
    You must be logged in to view attached files.
    #491
    RRowley
    Participant

    Which step is this occurring on? The import of structure.sql, or the import of your exported data?

    I just tested the import of structure.sql without an issue, so don’t understand if that is issue.

    If in the import of exported data, make sure that there is no logic to create tables. There should only be INSERT statements in that file. If it has CREATE and ALTER statements, delete them all and keep only the statements that will import data. Also when importing make sure to UNCHECK the “Enable foreign key checks” option prior to executing the import.

    #492
    esteeven
    Participant

    Odd. Odd. Odd. 🙂

    I got frustrated and decided to restore a back up of everything that I had made earlier (before this process began) from within SI. I deleted the tables in tsp_invoices and then imported the back up. Suddenly, as if by magic, I can Manage Products in Version: 2019.1.1 . There’s still the issue with the currency symbols to deal with but I want to set up a database copy to test on.

    The error occurred when I was importing the actual data. I suspect it may have been my dump of the data ie I think I left “structure” ticked (as well as data.) Do you think this may have caused the issue?

    Once again, many thanks for your patience and help.

    #493
    RRowley
    Participant

    Yes, having the create table statements is what the problem is. I thought that I had specified that you should not include the structure but in reviewing step 2 of the instructions, I didn’t spell this out. Sorry about that. The instructions and database structure I provided are for the master_2019.2.1_beta version and at this point, I would not use them per the following info.

    At this point if you are up on master_2019 (version 2019.1.1) and want to get to the most current master_2019.2.1_beta version (version 2019.2.4), load the updated SI software and run it. In theory, it should update the database and run smoothly, especially with fixes I implemented per your previous load attempts.

    #494
    esteeven
    Participant

    Hello

    Thanks for that. I thought I was going mad for a few minutes the other day. I simply couldn’t work out what was going wrong. A process of elimination led me to my conclusion in my earlier post. Your instructions have been really helpful : the problem is solved (for now) and I’ve gained a confidence in the power if phpMyAdmin.

    (My)SQL is something I’ve always avoided direct contact with but this has made me realise that it’s time I at least dipped more than a toe in the water.

    I will, in due course, update to master_2019.2.1_beta version (version 2019.2.4) Many thanks for that pointer too.

    For the record, I set up SimpleInvoices for my client years ago and it has been happily chugging along without issues. I set it up as a favour : she was just starting out in her business and needed an accounts package that was low cost. The set up, though outside my normal business (IT support & repairs) was straightforward and, once running, rock solid. She had her first and only glitch with emails and export to PDF a few weeks ago. That’s kind of sorted now:thanks to you!!

    The final issue is the back ups and restoration seems to have lost the invoice formatting I set up years ago. Can you point me in the right direction for the following?

    1 how do I make the “notes” field from invoice creation appear on the actual PDF invoice?
    2 how do I stop fields appearing on the PDF (or other export) if the field is blank ie customer fax?

    Again, many many thanks.

    ps I can start a new thread for the above request if you feel it is more helpful 🙂

Viewing 15 posts - 31 through 45 (of 52 total)
  • You must be logged in to reply to this topic.