Something went wrong, please try saving the invoice again

SimpleInvoices Group Forum Forums Fearless359 SimpleInvoices Discussion Group Something went wrong, please try saving the invoice again

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1752
    kerryww
    Participant

    Hi.

    I have my SI hosted with Dreamhost (shared). Recently they upgraded their MySQL server to MySQL 8.

    Now when to try to save an invoice, I get the error: Something went wrong, please try saving the invoice again.

    Before I start trying to rebuild my database or something, I thought I’d check here for any ideas.

    TIA.

    Kerry.

    #1768
    RRowley
    Participant

    First, check the web server (Apache?) log files to see is anything is reported there. Next check the PHP error log file. The next step would be to set the SI logger lever to DEBUG (custom.config.ini loggerLevel = DEBUG). Recreate the error and look at the tmp/log/si.log file and see where it ends. That is where the process stopped. Hopefully that guides you to the problem.

    I did check out the mysql 8 vs mariadb which I use and they are SQL compatible. So I don’t suspect an issue there.

    #1769
    kerryww
    Participant

    Hi. Thanks so much for your help! Much appreciated!

    Here’s the error from the websites root directory PhP.log file.

    [23-Jul-2022 13:33:15 America/Los_Angeles] PHP Warning: “continue” targeting switch is equivalent to “break”. Did you mean to use “continue 2”? in /home/ozwebexp/ozwebexpress.com.au/simpleinvoicesmaster/simpleinvoices-master/library/HTMLPurifier/HTMLPurifier.standalone.php on line 10943

    I tried to go to line 10943 of HTMLPurifier.standalone.php and add a “2” after “continue” but no love there.

    I’ve also included a copy of the PhP.log file from tmp/log/php.log

    There is nothing in the the tmp/log/si.log file. Nor is there anything in the Apache file.

    Thx again for your help.

    Kerry

    #1770
    kerryww
    Participant

    Here are the error files.

    Attachments:
    #1773
    RRowley
    Participant

    It appears you running SI version master_2019.2. Is there any reason you can’t updated to master_2020?

    #1774
    kerryww
    Participant

    Hi.

    I tried to do an update a couple of years ago and ran into problems. What I had runnung, was working, so I just stayed with the old version.

    I have tried to update with a copy on my localhost but up came this error:
    SqlPatchManager::runSqlPatch() error. See error log for more information.

    I first started using SI back in August 2006. So that’s 16 years I’ve been using SI. It has been a very good run.

    But, I’ve deceided to move on. I’ve spent days trying to get SI to work but it just keeps ending in errors, errors and more errors. I give up.

    I thank all the people involved with SI and wish you all the best for the future.

    Thanks again for your help.

    Kind regards

    Kerry Whitfield

    • This reply was modified 1 week, 5 days ago by kerryww.
    • This reply was modified 1 week, 5 days ago by kerryww.
    #1777
    RRowley
    Participant

    Sorry that you feel you need to move on. Do you recall the SqlPatchManager error you encountered? And have you tried to update recently?

    #1778
    kerryww
    Participant

    I uploaded the 2020_2 files and updated the config file but I get the page shown in the screenshot. When I press the Update button I get this error
    SqlPatchManager::runSqlPatch() error. See error log for more information.

    When I go to the error log in /tmp/log/php.log there is nothing there.

    #1780
    RRowley
    Participant

    This is actually the 2019.2 update and this stop is not unexpected. The issue is likely an orphaned record in the database that prevents the foreign key update from applying. You need to look at the error information in the tmp/logs/php.log file. It details what record(s) are at issue. If you want to display that information here or zip and attach the log file, I will look at it and let you know what can be done.

    You can also look at the “Unable to set Foreign Keys Error Handling” topic in the “Version Update Process” menu option on the left.

    NOTE: The php.log file might contain secure information. Be sure to scrub it before attaching/publishing it.

    • This reply was modified 1 week, 2 days ago by RRowley.
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.