SI 2011 can not see the invoices

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1466
    radiocampustours
    Participant

    Hello,

    I use to edit invoices with that great tool ! RRowley has helped me a lot for Radio Campus Tours. We can use the SI 2020 with pleasure.

    I am also used to use SI as I am producing DJ set. Unfortunatly the SI 2011 does not want to show me the old invoices. I do not know what to do to solve that bug and to update to SI 2020. I can see my guests, the articles. I can see the invoices in my db. I need a bit help please. I use php 5.6.18 and mysql 5.7.11.

    Regards

    Stéphane

    #1468
    RRowley
    Participant

    If you are running SI 2011, you should try to update to master_2019.2. I should work with your level of PHP. The update is pretty straight forward.

    1. Backup your database
    2. Copy your SI in to another backup directory.
    3. Delete all the sub-directories in your SI directory.
    4. Unzip the master_2019.2 zip file content into your empty SI directory
    5. Copy the config/custom.config.php file from your copy of the old SI into the config directory of your existing SI directory. If you don’t have a custom.config.php, copy the config/config.php after renaming it to custom.config.php
    6. Run SI. I should show you that there are a number of updates that need to be applied. Do this.
      You might be stopped at the update that adds foreign key support if you have orphaned records in your database. If so, look at the instructions in the error message and see if you can resolve it. If not, get back to me.
    #1476
    radiocampustours
    Participant

    Hello,
    I just did what you told me. I have an error concerning Claz. I embed an image to explain. What should I do next please ?
    Regards
    Stéphane

    #1479
    RRowley
    Participant

    For SI master_2019.2, you need to be on PHP 7.2 at a minimum. PHP 7.4 preferably and 7.4 required for SI master_2020. Any reason you can’t do this?

    #1487
    radiocampustours
    Participant

    Hello,
    Thx for the tip. As I run with php 7.2.7 / Mysql 5.7.11 I can access to the patches page. As I click on patch I have an error “SqlPatchManager::runSqlPatch() error. See error log for more information.” Here enclosed my php.log
    What should I have to do to fix that error please ?
    Regards,
    Stéphane

    Attachments:
    #1489
    RRowley
    Participant

    Check the content of your si_index table. There is probably only one record in it but could be more. Make sure each record contains a numeric 0 in the sub_node_2 column. It is probably blank but should be 0.

    #1490
    radiocampustours
    Participant

    Hello,
    I did add 0 in the sub_node_2 column as it was blank. I clicked on patch the I still have this error “SqlPatchManager::runSqlPatch() error. See error log for more information.” I enclose the php.log and I still do not know what I should have to do.
    Regards,
    Stéphane

    Attachments:
    #1493
    RRowley
    Participant

    The error you are getting is:

    [14-Apr-2021 14:02:04 Europe/Paris] SqlPatchManager::runSqlPatch() - PdoDb - query(): Execute error. See error_log.
    [16-Apr-2021 17:05:34 Europe/Paris] PdoDb - debugger(): ALTER TABLE <code>si_invoices</code>
                            ADD UNIQUE INDEX <code>UniqDIB</code> (<code>index_id</code>, <code>preference_id</code>, <code>biller_id</code>, <code>domain_id</code>),
                            ADD INDEX <code>IdxDI</code> (<code>index_id</code>, <code>preference_id</code>, <code>domain_id</code>);
    [16-Apr-2021 17:05:34 Europe/Paris] PdoDb - query(): Execute error.Array
    (
        [0] => 42000
        [1] => 1067
        [2] => Invalid default value for 'date'
    )

    If you look at the si_invoices structure, you should see that the date column is set to NULL = NO and Default of 0000-00-00 00:00:00. You need to make sure that zero dates are allowed in your database. Do this by commenting out the “sql_mode=” in the my.ini file.

    For reference, make the current setting for this value into a comment by adding a # at the front of the line. An example of what this line might be set to is, sql_mode=NO_ZERO_IN_DATE,NO_ZERO_DATE,NO_ENGINE_SUBSTITUTION.

    After you make this change, restart your mysql server and access SI again.

    • This reply was modified 7 months, 2 weeks ago by RRowley.
    #1495
    radiocampustours
    Participant

    Hi,
    Thx a lot for the tip. I have applied the patches. SI 2019-2 seems to be ok except that I can not the see the invoices in the list. It stays on loading. I do not really understand this bug I already had before.
    Regards
    Stéphane

    #1497
    radiocampustours
    Participant

    [EDIT] The bug has been solved as I set the french language in the invoice settings and in the software.
    Regards
    Stéphane

    #1521
    radiocampustours
    Participant

    Hello,
    I have a new bug as I want to check the products that can be sold. As I click, an error appears “DataTables warning: table id=si-data-table – Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1&#8221;
    What should I have to do to solve it please ?
    Regards,
    Stéphane

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.