Fatal error: Uncaught TypeError: Return value of Inc\Claz\Export

SimpleInvoices Group Forum Forums Fearless359 SimpleInvoices Discussion Group Fatal error: Uncaught TypeError: Return value of Inc\Claz\Export

Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #1022
    facer
    Participant

    happy to hear you got some more information out of our daily routine 😉

    Attachments:
    You must be logged in to view attached files.
    #1024
    RRowley
    Participant

    OK, hopefully I am drilling into it. It seems like for some reason, the source field is not being returned as part of the si_sql_patchmanager table. I have attached another update for the PdoDb.php file for you to test with. It will generate even more information in the php.log file. As before, put the PdoDb.php file in the Inc/Claz directory and delete the tmp/log/php.log file before you test. Then give me the new php.log file so I can drill through it.

    Attachments:
    You must be logged in to view attached files.
    #1026
    facer
    Participant

    let’s drill into number 7.

    Attachments:
    You must be logged in to view attached files.
    #1028
    RRowley
    Participant

    Check out the attached pictures and test with the new PdoDb.php file.

    Attachments:
    You must be logged in to view attached files.
    #1031
    RRowley
    Participant

    Here the updated PdoDb.php file.

    Attachments:
    You must be logged in to view attached files.
    #1035
    facer
    Participant

    first the result log

    Attachments:
    You must be logged in to view attached files.
    #1037
    facer
    Participant

    Well this is way above my knowledge with phpmyadmin. I did as best I could understand what you wrote.
    I typed the whole row from your picture in phpmyadmin.
    Picture say more than words. as a result.

    Attachments:
    You must be logged in to view attached files.
    #1040
    facer
    Participant

    I typed the whole line from your picture:

    Maybe you meant it differently ?

    I noticed I could not copy paste the code line in the forum.

    • This reply was modified 4 months ago by facer.
    #1042
    RRowley
    Participant

    I attached the command to use in a text file. Note that it has backticks around database related names and single quotes around strings. Also, the picture had my database name in it. The text has yours, so the command should be able to be cut and pasted into the SQL command box.

    OOPS, looks like this interface doesn’t like txt files. So I zipped it.

    • This reply was modified 4 months ago by RRowley.
    Attachments:
    You must be logged in to view attached files.
    #1045
    facer
    Participant

    and here is the result of the command in the attached picture

    Attachments:
    You must be logged in to view attached files.
    #1047
    RRowley
    Participant

    Try this version of PdoDb.php. I made a change that might resolve the issue.

    Attachments:
    You must be logged in to view attached files.
    #1049
    RRowley
    Participant

    What do you get if you run this command:

    SHOW variables like 'LOWER_CASE_TABLE_NAMES'

    #1050
    RRowley
    Participant

    If the result of the previous query is LOWER_CASE_TABLE_NAMES 0, then I suspect you are running on a system that is using a case sensitive file system. So while the change I made fixes the issue you are having (hopefully), there are other issue that will be encountered.

    The fix, I believe, is to set LOWER_CASE_TABLE_NAMES to 2. This performs all comparisons in lower case. Unfortunately, you have to make this change in the configuration file. You will have to find this file and add the following to it.

    First, look to see if there is a section for [mariadb]. If not add this section at the end of the file. If it does exist, you don’t need to add this section.

    Immediately following the mariadb section line, add the following:
    lower_case_table_names=2

    Save the configuration file and restart your mysql database and test SI. Hopefully this will solve your problem.

    Attachments:
    You must be logged in to view attached files.
    #1058
    facer
    Participant

    It seems that from mysql 8 and mariadb 10.2 on this setting can not be changed easily.
    when I set lower_case_table_names=2 in my.cnf it gives errors and mysql won’t start.
    Then I red that it can only be configured when initializing the server. Changing the lower_case_table_names setting after the server is initialized is prohibited.

    removed all and reinitialized mariadb but nothing works with the newer version on Linux.
    It always comes up with: mysql: unknown variable ‘lower_case_table_names=2’

    Although I learned a lot. I have to give up and I will setup a new fresh database and start brand new.
    This is way above my head, I am reading lot’s of people with newer Mysql/mariadb versions having trouble Changing the lower_case_table_names setting.

    Thank you for all your work !

    #1059
    RRowley
    Participant

    Before you go to that trouble, let me look at a programmatic solution. Also, did you try the new version of PdoDb.php and did it get you past that problem. You might encounter another problem, but it is important to know if it got you past the current one.

Viewing 15 posts - 16 through 30 (of 40 total)
  • You must be logged in to reply to this topic.