change pdf font size

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1653
    oab2
    Participant

    When I edit config/custom.config.php and change export.pdf.defaultfontsize = 7 no change to the appearance of my exported pdf changes. Is there another location to edit pdf settings?

    #1654
    RRowley
    Participant

    Check the version of SI you are on. If master_2020, the config/custom.config.php is no longer used. The config/custom.config.ini is used and that is where you should make changes. If not on master_2020, you should update to it before reporting an issue.

    #1655
    oab2
    Participant

    You are correct, I was using 2019.2. I have gone through the steps to update to master2020. However, now when I go to index.php I am in a loop. It states database has been updated, click to install essential data. When I click it then states “data has been imported, click to start using SI”. Clicking just takes me back to “database has been update, click to install essential…” This is an endless loop.

    My server is set to php 7.4. My next option is 8 and that throws an error.

    #1656
    RRowley
    Participant

    In your database, what is the greatest value of the sql_patch_ref field in the si_sql_patchmanager dataset. If the dataset is not empty, the greatest value should be 319. This is the greatest patch number applied in master_2019.2 and master_2020 begins it patch settings from there, starting at 320. If this dataset is empty, you are doing a fresh install an the essential data adds patches 319 through 326 (or greater when future patches added) to the dataset.

    Things to also check:

    1) In config/custom.config.ini, make sure the database settings are correct. I suspect they are because the code is acting as though it can access the database.

    2) Check the tmp/log/php.log file and see if there is an error being reported. If you are unsure of the error info being from your last test, delete the content and save the empty file. Then access SI again to recheck the content of this file.

    3) Delete the tmp/log/si.log file if there is one. Then in the config/custom.config.ini file set the loggerLevel to DEBUG. Run your access again and see what gets logged.

    You can zip either the php.log or si.log file to this forum if you want me to look at them. Although, you should sanitize the confidential data in either file. There probably isn’t any in the php.log, but you will see database names and passwords and possibly email names and passwords in the sl.log file. Just replace these with x’s as nobody but you needs to see them.

    #1657
    oab2
    Participant

    Thank you for your continued help. Here is what I found:

    sql_patch_ref greatest value is 319

    1) Confirmed database settings are the same in config/custom.config.ini as my last 2 config files (2019.2, 2011.1)

    2) Deleted contents of php.log, no content added to file after trying to access SI and clicking through the loop a couple times.

    3) Attached si.log below. Order of my entries: entered SI root in address bar, clicked on install essential data, clicked on start using SI

    #1658
    oab2
    Participant

    Sorry should have zipped it.

    Attachments:
    #1660
    RRowley
    Participant

    I’ve attached a zip file with an update index.php file in it. Use this in place of the one you have in your root SI directory. Reset your database to what it was before the upgrade and run SI to see if this doesn’t resolved the issue. Let me know what happens, good or bad.

    • This reply was modified 7 months, 1 week ago by RRowley.
    Attachments:
    #1663
    oab2
    Participant

    Good news! I install the new index.php and it then showed me the updates to be made. I clicked proceed and it stated that it successfully updated the database. Checking my si_sql_patchmanager shows 326 for my patch reference. I am able to log in to SI and use it as normal. Further more I am able to adjust my default pdf font in custom.config.ini.

    I really appreciate the help! I am assuming the older index.php was not updating the sql database? My update had been from 2011 to 2019.2 and then master_2020.

    #1664
    RRowley
    Participant

    Great news. The issue evolved around the last update required for master_2020 being 319 and that being the last update you had. Why this hasn’t happened before, I don’t know. But I’ll post the fix and it shouldn’t happen to others. Thanks for helping work this out.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.