Booking Payments Results in Invalid Number Error

SimpleInvoices Group Forum Forums Fearless359 SimpleInvoices Discussion Group Booking Payments Results in Invalid Number Error

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1858

    Hello. I’m having an issue when attempting to book payments for an invoice. Here are a few details:

    Language is set to de_DE in custom.config.ini:
    versionName = 2020.4.6
    versionUpdateDate = 20221220

    localLocale = de_DE
    localCurrencyCode = EUR
    localPrecision = 2

    Also the Invoice Preferences for Language and Locale are set to de_DE.

    I’ve followed the instructions provided regarding Installation, How To, Common Problems etc. (and thank you for the detailed and extensive documentation). Maybe I just missed a setting somewhere, but it appears that the page for payments cannot handle the comma as a decimal separator.

    For example I have an invoice with the following totals:
    Total: 5.460,75
    Paid: 0,00
    Owing: 5.460,75

    When 5.460,75 is entered in the Amount field I get the following message: “Please enter a valid number” (see attached image).

    Just to test if maybe the on the payment screen the amount should be entered with a dot as the decimal separator (5460.75) results in the following error: “WARNING Payment amount (5.460,75 €) exceeds amount owing (5,46 €). Excess will be warehoused if left unchanged.”

    Which tells me that it’s reading the amount owing 5.460,75 (five thousand four hundred sixty euros and seventy five cents) as five euros and forty-six cents. So, with a comma as the decimal separator I get a “Please enter a valid number” error and with a dot as a decimal separator the amount is completely off.

    If the amount is a whole euro value entered without a dot or comma, the payment gets booked correctly. To get around this issue and be able to book payments with cents, we have been changing the custom.config.ini file to “localLocale = en_US” temporarily to book the payments and then back to de_DE.

    I hope I’m not too confusing in trying to explain the issue. Also, please let me know if any further details are needed. Any advise or suggestions would be greatly appreciated. Thanks.


    Update to my previous post.

    I upgraded to the latest version:
    versionName = 2020.4.9
    versionUpdateDate = 20230310

    However the issue regarding the booking of payments remains the same. Just want to make sure the information provided is up to date. Thanks.


    This is an issue that will take some time to resolve. In the mean time, if you modify the templates/default/payment/process.tpl at line #48 to remove the validate-number class, your payment should work. This bypasses the interactive, at entry time, field validation which is what isn’t honoring your globalization settings.


    Thank you for looking into the issue. I totally understand that it will take some time to resolve. In the meantime, I’ve applied the proposed modification and booked out several payments as a test. The proposed fix solves the issue for the time being and allows us to book payments.

    We still get a warning when an amount is entered manually, for example for a partial payment, saying (that the Payment amount exceeds amount owing. Excess will be warehoused if left unchanged), but upon processing the system applies the payment correctly to the invoice without any amount being warehoused. So I’ll just be ignoring that warning for now.

    Again, thanks for your assistance and I will keep an eye out for any future version updates.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.