Reply To: SI 2011 can not see the invoices

#1493
RRowley
Participant

The error you are getting is:

[14-Apr-2021 14:02:04 Europe/Paris] SqlPatchManager::runSqlPatch() - PdoDb - query(): Execute error. See error_log.
[16-Apr-2021 17:05:34 Europe/Paris] PdoDb - debugger(): ALTER TABLE <code>si_invoices</code>
                        ADD UNIQUE INDEX <code>UniqDIB</code> (<code>index_id</code>, <code>preference_id</code>, <code>biller_id</code>, <code>domain_id</code>),
                        ADD INDEX <code>IdxDI</code> (<code>index_id</code>, <code>preference_id</code>, <code>domain_id</code>);
[16-Apr-2021 17:05:34 Europe/Paris] PdoDb - query(): Execute error.Array
(
    [0] => 42000
    [1] => 1067
    [2] => Invalid default value for 'date'
)

If you look at the si_invoices structure, you should see that the date column is set to NULL = NO and Default of 0000-00-00 00:00:00. You need to make sure that zero dates are allowed in your database. Do this by commenting out the “sql_mode=” in the my.ini file.

For reference, make the current setting for this value into a comment by adding a # at the front of the line. An example of what this line might be set to is, sql_mode=NO_ZERO_IN_DATE,NO_ZERO_DATE,NO_ENGINE_SUBSTITUTION.

After you make this change, restart your mysql server and access SI again.

  • This reply was modified 7 months, 2 weeks ago by RRowley.