Reply To: Update SI from an old version

#2018
fearless359
Keymaster

In the schema you attached, the following is the id settings in si_invoice_items:

CREATE TABLE si_invoice_items (
  id int(10) NOT NULL AUTO_INCREMENT,

It should be:

CREATE TABLE si_invoice_items (
  id int(11) UNSIGNED NOT NULL AUTO_INCREMENT,

If the table is set correctly, then the update process should complete as it did once I made the change. Note, you can change the field setting manually in phpMyAdmin by selecting the Change option on the id column under the Structure tab when si_invoice_items is selected.

  • This reply was modified 5 months, 1 week ago by fearless359.