Unable to create public/data.json file

SimpleInvoices Group Forum Forums Fearless359 SimpleInvoices Discussion Group Unable to create public/data.json file

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #798
    ramanc51
    Participant

    Hello thanks so much for your effort, i am using simpleinvoices_2019_master on my fedora system with PHP7.2.18, while click manage product and customer i got following error, how to resolve it, could you help me resolve it?, error screenshot attached

    Unable to create public/data.json file

    Attachments:
    You must be logged in to view attached files.
    #800
    RRowley
    Participant

    Make you sure you have directory, “public”, with access 755. You can also look in the tmp/log/php.log file to see if there is a better explanation of the error.

    #801
    ramanc51
    Participant

    Hello thanks to your reply, my issue has been resolved now, after creating public folder error disappeared.

    • This reply was modified 4 months ago by ramanc51.
    #803
    ramanc51
    Participant

    Hello i created one invoice, sub total and tax amount missed, i set IGST tax type with 18% value, but it seems that it is not reflected on my invoice, also sub total how to enable both?, invoice attached.

    • This reply was modified 4 months ago by ramanc51.
    Attachments:
    You must be logged in to view attached files.
    #806
    RRowley
    Participant

    Is this a custom invoice template? Regardless, attach the invoice template you are using to a response to this message so I can look at what it is doing.

    #807
    ramanc51
    Participant

    No sir, i didn’t use any template, this quote generated only using our simpleinvoices_2019_master, i added Indian currency HTML code, Tax rate and logo

    #808
    RRowley
    Participant

    This is what I get when I use the default template. You might try updating to the master_2019.2 version and see if that affects your results.

    If that doesn’t work first verify in the SI Defaults that you have the Default template selected and then zip your folder with the invoice template you are using and attached it to your response and I’ll check it out.

    Attachments:
    You must be logged in to view attached files.
    #810
    RRowley
    Participant

    Also, be sure to check the SI Default setting for Default Invoice Template. Per what you have written, it should show “default” as the setting.

    #812
    ramanc51
    Participant

    thanks sir, master_2019.2 working as expected, find out attachment of generated invoice/Quote, few errors found

    1) While creating new invoice/quote default rows created not useful also not reflected after saving that invoice/quote

    2) if i add one more new row then selected product/item value not loaded automatically, we need to enter manually

    3) found few extra character on description filed

    remaining all are seems OK

    • This reply was modified 3 months, 3 weeks ago by ramanc51.
    Attachments:
    You must be logged in to view attached files.
    #815
    ramanc51
    Participant

    Find this attachment

    Attachments:
    You must be logged in to view attached files.
    #817
    fearless359
    Keymaster

    Please provide me with a zip file of the templates/invoices directory and upload it. Also, give me a screen shot of the SI Defaults screen and of any other screen that shows something that it shouldn’t.

    #818
    ramanc51
    Participant

    Sir find attachment of templates/invoices directory and si default screen shoot

    Attachments:
    You must be logged in to view attached files.
    #821
    fearless359
    Keymaster

    Ok, I believe you must be overriding the default template. This means your template is in the custom/default_template directory. If this is the case, you can move the files out of this directory (saving them). You will then be using the standard SI default template. Test that. Then you can move your files back to the custom/default_template directory and start fixing them to work how you want.

    Let me know what your find.

    • This reply was modified 3 months, 3 weeks ago by fearless359.
    • This reply was modified 3 months, 3 weeks ago by fearless359.
    #826
    ramanc51
    Participant

    ok thanks, but i don’t have idea/knowledge on PHP, i need only one modification/update on your simpleinvoices-master_2019.2 verdion

    if i add one more new row, price of selected product on this new row is not loaded automatically, we need to edit it manually

    if this issue/option is corrected then this version is almost usable to me, thanks your support.

    • This reply was modified 3 months ago by ramanc51.
    #828
    RRowley
    Participant

    I just upload changes to fix the setting of the unit price when the invoice item product changes. Also fixed issues when adding new lines (part of the price issue) and problems with not being able to delete lines.

    Download the current 04/01 (no April fools) version and see if this doesn’t address your issues.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.