“PAID” Invoices not showing in “money” – 2019.2

SimpleInvoices Group Forum Forums Fearless359 SimpleInvoices Discussion Group “PAID” Invoices not showing in “money” – 2019.2

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1349
    xpuser8334
    Participant

    After upgrading to 2019 – i upgraded to 2019.2 but now I have no invoices showing in my grid.

    Only invoices in the “due” tab will be displayed – any paid invoices are not shows.
    Version 2019 worked perfectly.

    Please help 🙂

    • This topic was modified 2 weeks, 4 days ago by xpuser8334.
    • This topic was modified 2 weeks, 4 days ago by xpuser8334.
    #1353
    xpuser8334
    Participant

    Sorry – My Invoices had the Set Aging box enabled.

    #1356
    RRowley
    Participant

    Typically you would have Set Aging enabled for your invoices. Otherwise, you won’t get any aging information in the Aging column. You might want to disable it on Quotes, Estimates, etc. because you aren’t looking for past due information on those invoices.

    Were any errors reported to the tmp/log/php.log file? If so, I’d be interested in looking at that file. You would need to zip it in order to attach it.

    I’d also be interested in knowing what happens if you set the Invoice INV PREFS record Set Aging field to Enabled.

    #1357
    xpuser8334
    Participant

    Yes I had an issue – I had a problem loading patch 318 – but that needed some MyPHPAdmin work to re ID the user accounts. – Log Attached

    I went a step further and upgraded y copied installation to 2020 and PHP7.4
    All seems ok but there are one or two things I will raise in another question. due to zero owing when the invoice is new and not been submitted to the customer or paid yet.

    Attachments:
    #1360
    RRowley
    Participant

    Sorry to tell you this, but you probably have a data base that does not have the proper foreign keys enabled. It will work, but you won’t be protected from orphaned records.

    The 318 error you had is telling you that you have orphaned records in your database. This is what was in your log:

    FOREIGN KEY TABLE         COLUMN              REFERENCE TABLE          COLUMN     INVALID VALUE
    ------------------------  ------------------  -----------------------  ---------  -------------
    user                      domain_id           user_domain              id         4
    user                      domain_id           user_domain              id         3
    user                      domain_id           user_domain              id         2

    Basically this is telling you that there are three records in the si_user table with the domain_id set to 2, 3 and 4 which do not have parent records for those domains in the si_user_domain table. The best solution is to create these records in the si_user_domain table and run the master_2019.2 installation again; assuming you can back up that far.

    If you can load back to where you were prior to loading master_2020, this is what you should do. This way, the foreign key constraints implemented in patch 318 will succeed and every thing will be hunky dory.

    Otherwise, you can make the fix above and import the sql file in the attach zip file which hopefully, will apply all the foreign key constraints to you master_2020 database.

    Let me know how it turns out.

    #1362
    RRowley
    Participant

    I forgot to a a COMMIT; line at the end of the sql file. So I’ve attached an update version with this message.

    #1366
    xpuser8334
    Participant

    Thank you – much appreciated..

    Yes – I have several backups of my database and folder structure – so I’m having another go at upgrading from “2011.1 – stable” again.

    Obviously I have to use two different PHP Versions to do this which is fun in itself.

    Kindest Regards
    Wayne

    #1367
    RRowley
    Participant

    Sounds like you have a definition of “fun” similar to mine. Good luck.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.