Customer management on 2019.2.27

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #927
    ExpertGeeks
    Participant

    I upgraded to 2019.2.27 today to mitigate this bug as per the instructions on that page. However in this version I’m unable to ‘manage’ customers. When pulling up the /index.php?module=customers&view=manage page I get ‘Loading’ as per the attached image instead of the list of customers. Loading doesn’t complete. I reverted back to 2019.2 and loading completes as before.

    Attachments:
    You must be logged in to view attached files.
    #931
    RRowley
    Participant

    Have you looked at the tmp/log/php.log file for an error? I assume the list of invoices on the primary screen shows correctly. If not, make sure that a public directory exists in the SI directory structure.

    #935
    ExpertGeeks
    Participant

    there’s two logs in tmp/log/, paypal_ipn_results.log & si.log – both are empty.
    public folder exists and is writeable and invoice list shows correctly.

    There’s nothing in apache error log.

    #960
    RRowley
    Participant

    In your config/custom.config.php file make sure you have the following settings:

    debug.level                         = All
    debug.error_reporting               = E_ALL & !E_DEPRECATED
    
    zend.logger_level                   = DEBUG

    The debug settings are probably already set this way. But if not, will cause runtime errors to be reported in the tmp/log/php.log file.

    The zend.logger_level setting will have a lot of debug information to written to the tmp/log/si.log file.

    If your problem still exists, zip these files together and attach to a message added to this thread.

    #975
    ExpertGeeks
    Participant

    By default debug.error_reporting was set to = E_ERROR, zend.logger_level was set to = EMERG. Here’s the si.log (no other logs have any content). Cheers!

    Attachments:
    You must be logged in to view attached files.
    #977
    RRowley
    Participant

    I’m assuming that you changed the defaults to the values I asked you to use. That being the case, no errors in php.log and the si.log content shows a normal execution of the customer list request.

    First thing to do is while this command is executing, take a look that the public/data.json file. You should see your customer information in it.

    Assuming that is the case and it looks good, I’d like you zip your SI directory and attach it to a reply to this message. The zip file will be too big if you include all directories, plus the config directory contains personal info that should not be shared. So I have attached a picture that shows what directories and files to include. Using this, I can compare what you have with what I have to see if for some unknown reason, you have some different files than you should.

    It is a long shot, but I’m not sure what else to suggest at this point.

    • This reply was modified 3 months, 1 week ago by RRowley.
    Attachments:
    You must be logged in to view attached files.
    #983
    ExpertGeeks
    Participant

    Yes I changed the defaults as requested. I can see customer info in the public/data.json file. Please find attached the files/folders listed. Thanks.

    EDIT: Can’t upload, apparently the 2.5Mb zip is above filesize limit. Do you want me to break in into chunks or can you raise the limit ? Thanks.

    • This reply was modified 3 months, 1 week ago by ExpertGeeks.
    #989
    ExpertGeeks
    Participant

    At login I get the following error appear in the apache error log (attached).

    PHP Warning: fwrite() expects parameter 1 to be resource, bool given in /var/www/html/simpleinvoices/Inc/Claz/Config.php on line 239

    • This reply was modified 3 months, 1 week ago by ExpertGeeks.
    Attachments:
    You must be logged in to view attached files.
    #992
    RRowley
    Participant

    The error indicates that SI was not able to create a custom.config.php.new file in the config directory. Check that the directory has 755 as its access (assumes non-windows system). On windows, the directory needs to read/write access for the user.

    #993
    ExpertGeeks
    Participant

    It’s now owned by www-data and is set to 0755.. It’s still not loading up a list of customers sadly. Manage products page does the same.

    • This reply was modified 3 months, 1 week ago by ExpertGeeks.
    #995
    ExpertGeeks
    Participant

    The previous version of simpleinvoices only tmp and public are owned & writeable by www-data. Are there other folders in this new version that www-data needs to write to ?

    #996
    RRowley
    Participant

    You lost me with the www-data. On my windows 10 development system, the windows permissions give full control to my administrative user same as any other windows folder. However, if I look at the folders through the Git Bash window, I see the 755 for window permissions on all directories including tmp and public.

    I modified the Inc/Claz/Config.php file to catch the error when the new file is opened rather than when the attempt is made to write to it. This doesn’t fix your error, but kills the request and reports the error where it occurs.

    Try this to verify error occurs at attempt to open the new file for write access. If not there, then the resource handle is being corrupted after being opened and that information would be helpful.

    Attachments:
    You must be logged in to view attached files.
    #1052
    ExpertGeeks
    Participant

    thanks @RRowley, here’s the si.log.

    I’m running this on a linux host, www-data is the default user that runs the web service so if this user has read/write access it means that php scripts also have access.

    Attachments:
    You must be logged in to view attached files.
    #1054
    RRowley
    Participant

    OK, that looks normal. Please send me a zip of the Inc/Claz, modules and templates directories so I can compare them to what I have.

    #1055
    RRowley
    Participant

    One thing you might try is to increase the time allowed for a query to process. In your php.ini file, find the line, “max_execution_time”, and double the value that is assigned to it and save the change. Then restart your webserver (apache) and try to list customers again.

    • This reply was modified 2 months, 4 weeks ago by RRowley.
Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.